My perfect brightside paint went to hell after 5 days?

View previous topic View next topic Go down

My perfect brightside paint went to hell after 5 days?

Post by sactownie on June 27th 2013, 1:36 am

Well I am about to throw in the towel. After 2 months of off and on problems painting my hood and roof with interlux brightside I thought I finally had all the problems solved.
6 days ago I did what was going to be my last coat, take it or leave it, and surprisingly both the hood and roof turned out perfect. Well yesterday I had to move the vehicle from under the car port to the uncovered part of the driveway and today I go out and the roof looks like hell. the gloss is completely gone and you can see all the scratches from a previous coat. it looks completely different from yesterday as if someone overnight took a scotch bright pad to it during the night! The hood is still mostly glossy but some parts are looking a little like the roof and when I take my light to it I can see what looks like crows feet forming.
Anyone know what could have happen after drying for 5 days for it to just go to hell on the 6th day? I am dumbfounded. Like I said it looked perfect yesterday.
avatar
sactownie
Rank
Rank

Number of posts : 10
Age : 46
Location : Antelope CA
Project : 2000 Dodge Dakota R/T
Registration date : 2013-03-16

View user profile

Back to top Go down

Re: My perfect brightside paint went to hell after 5 days?

Post by street_ride14 on June 27th 2013, 8:44 am

what are your mix ratios?
are you using a drying catalyst?
what is your process in cleaning your surface before applying your next paint coat?

I'm not too familiar with interlux brightside paint, but it may have reacted with your original paint under it. Did you take down all of the original paint, or paint right over?
avatar
street_ride14
Rank
Rank

Number of posts : 15
Age : 32
Project : 1991 Honda CRX
Registration date : 2013-03-23

View user profile

Back to top Go down

Re: My perfect brightside paint went to hell after 5 days?

Post by sactownie on June 27th 2013, 2:24 pm

I mixed it with mineral spirits until the paint was dripping off the stir stick at about the count of 12.dont know the ratio for sure but its probably around 10-15%, no catalyst and the surface was wetsanded 800grit between coats then wiped down with rubbing alcohol.
looking at it now during daytime the hood just has one little area thats splotchy and it looks as if the final polishing will take care of that, the roof on the other hand looks terrible where it had direct contact with the sun. the rear sides that didn't get exposed to sunlight look perfect still.
Maybe i need another coat on the roof, it only has 3 coats and the hood has like 7.
I also believe it has something to do with the humidity, it rained (very rare event in june in california) the day before i took it out from the car port.
Guess Ill try unthinned paint next coat on the roof and make sure I leave it under the carport for at least 2 weeks.
avatar
sactownie
Rank
Rank

Number of posts : 10
Age : 46
Location : Antelope CA
Project : 2000 Dodge Dakota R/T
Registration date : 2013-03-16

View user profile

Back to top Go down

Re: My perfect brightside paint went to hell after 5 days?

Post by sactownie on June 27th 2013, 2:36 pm

Here are some photos, 1st taken right after applying that last coat. 2nd is today 6 days later.



avatar
sactownie
Rank
Rank

Number of posts : 10
Age : 46
Location : Antelope CA
Project : 2000 Dodge Dakota R/T
Registration date : 2013-03-16

View user profile

Back to top Go down

Re: My perfect brightside paint went to hell after 5 days?

Post by ROCK&ROLL on June 27th 2013, 6:54 pm

Hello,

I have used one part boat paint like brightside, rustoleum and rustoleum boat paint in all kinds of constant and varying temperatures.

What will kill the gloss and leave a cloudy finish, maybe white spots is condensation, dew, humidity.

Too much of a drop in temperature before the paint has cured can cause this.



avatar
ROCK&ROLL
Rank
Rank

Number of posts : 6
Age : 55
Registration date : 2012-10-10

View user profile

Back to top Go down

Re: My perfect brightside paint went to hell after 5 days?

Post by sactownie on June 29th 2013, 9:09 am

Yea im thinking the drastic weather change did it and parking it in the sun after.
going to do 1 more coat on roof today and not move it from under car port for atleast 2 weeks.
On the brightside its only the roof, Id hate to be redoing a whole car!
avatar
sactownie
Rank
Rank

Number of posts : 10
Age : 46
Location : Antelope CA
Project : 2000 Dodge Dakota R/T
Registration date : 2013-03-16

View user profile

Back to top Go down

Re: My perfect brightside paint went to hell after 5 days?

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum